Bug #15681

Fog Openstack version should require at least version 0.1.7 to ensure compatibility with Openstack Liberty

Added by Imri Zvik almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assigned To:Imri Zvik
Category:Compute resources - OpenStack
Target version:-
Difficulty:trivial Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/3648
Story points-
Velocity based estimate-
Release1.13.0Release relationshipAuto

Description

Due to changes in Openstack, the Compute API in Liberty (and maybe other APIs) are no longer forgiving for empty values.
See the following commit: https://github.com/fog/fog-openstack/commit/13bfc96ba646c65487c8a619ee84ad5f6268e702

This totally breaks stuff like boot from volume.

Associated revisions

Revision e8bceb07
Added by Imri Zvik almost 2 years ago

Fixes #15681 - Upgrade Fog Openstack to at least version 0.1.7

This is need to ensure compatibility with Openstack Liberty and above.
The API since Liberty is less forgiving about empty parameters.
See fog/fog-openstack@13bfc96ba646c65487c8a619ee84ad5f6268e702

Revision 97ded51e
Added by Dominic Cleal almost 2 years ago

refs #15681 - require newer fog-core, fog-openstack

History

#1 Updated by Imri Zvik almost 2 years ago

Should probably be

gem 'fog-openstack', '~> 0.1', '>= 0.1.7'

#2 Updated by Dominic Cleal almost 2 years ago

The pinning of fog-core to 1.36.0 currently prevents the ~> 0.1 matcher from matching 0.1.7. If fog-core is updated to over 1.40 (either specifically, or unpinned) then we'll automatically inherit a newer version of fog-openstack too.

#3 Updated by Imri Zvik almost 2 years ago

Well, since this breaks the functionality quite bad, I think this should get priority.

Note that Liberty is the minimal version of Openstack still supported (http://releases.openstack.org/), so Foreman should probably be compatibable with it.

#4 Updated by Imri Zvik almost 2 years ago

Dominic Cleal wrote:

The pinning of fog-core to 1.36.0 currently prevents the ~> 0.1 matcher from matching 0.1.7. If fog-core is updated to over 1.40 (either specifically, or unpinned) then we'll automatically inherit a newer version of fog-openstack too.

btw, another thing to note is that nothing ensures you will get the latest version of 0.1 - see https://github.com/bundler/bundler/issues/3089#issuecomment-48533609 for example.
Therefore, it is probably a good idea to change the requirement anyway.

#5 Updated by The Foreman Bot almost 2 years ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Imri Zvik
  • Pull request https://github.com/theforeman/foreman/pull/3648 added

#6 Updated by Imri Zvik almost 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Dominic Cleal almost 2 years ago

  • Release set to 1.13.0

Also available in: Atom PDF